You are here

Installing OpenMx 2.0 in R 3.1.0 (building it from the source repository)

6 posts / 0 new
Last post
Bfcastilla's picture
Offline
Joined: 09/11/2014 - 09:07
Installing OpenMx 2.0 in R 3.1.0 (building it from the source repository)

Hi,

I'm a new user and I'm not familiar with programming...I'm trying to install OpenMx 2.0. (building it from the source repository) following the instructions attached in the next link :

http://openmx.psyc.virginia.edu/wiki/howto-build-openmx-source-repository

I succesfully create a new repository (with TortoiseSVN), and get to download all the files of OpenMx 2.0. However, I don't know the next step...according to the web site , I should "cd (change directory) to the trunk directory, and make install" (that is written under the section "Building and Installing OpenMx from the downloaded source"), but I don't know how to do it or where should I write/search for that command.

I'm new using R, and creating a package from the source repository seems quite difficult for me.

Thanks in advance,

RobK's picture
Offline
Joined: 04/19/2011 - 21:00
Windows, correct?

Since the only section of the instructions that mentions TortoiseSVN is the section for Windows, I will assume you're trying to build from source on a Windows machine. Thanks for your post--you've reminded me that I've been meaning to re-write that section. Also, if I'm wrong, and you use a different operating system, please correct me.

Usually, only advanced users build OpenMx from the source repository. Are you sure you need to do so? Are the current stable release and the current v2.0 beta not adequate for your needs?

Assuming you do, in fact, need to build from source, once you've checked out (downloaded) the files from the repository, you need to fire up the system command prompt. Its filename is cmd.exe, and you can probably find it as Start -> Accessories -> Command Prompt. If you have Administrator rights on your machine, right-click the icon and choose to run it as Administrator. Otherwise, just run it as you would any other program.

You'll need to navigate to the trunk folder of your checkout from the repository. The command might be something like

cd C:\OpenMx\trunk

Once you're in the trunk folder, enter make install at the command prompt. If everything is configured correctly, then you'll be installing OpenMx. If not, post again, for troubleshooting help.

Bfcastilla's picture
Offline
Joined: 09/11/2014 - 09:07
Thank you very much for your

Thank you very much for your answer! As you point out, I am using Windows 7 and the current stable release and v2.0 beta of OpenMx are not adequate for what I need...

I got to run "make install" function!! But an error appears...

Error : Invalid DESCRIPTION file

Malformed package version.

See the information on DESCRIPTION files in section 'Creating R
packages' of the 'Writing R Extensions' manual.

ERROR: installing package DESCRIPTION failed for package 'OpenMx"

Do you know what should I do to solve that? I really appreciate your help!!!

Kind regards,

RobK's picture
Offline
Joined: 04/19/2011 - 21:00
When you're at the Command

When you're at the Command Prompt, in the 'trunk' folder of your checkout from the repository, what do you see when you enter

bash inst\tools\findBuildNum.sh

?
How about if you enter

svnversion

at the prompt? Is there a file called 'DESCRIPTION' (with no file extension) in the trunk folder, and if so, what is on its last line of text? Also, do you have a 32- or 64-bit system?

There are two things I can think of that you could try, but I'm not sure if they will make a difference, because I'm still not sure why the problem is happening. First, you should probably try using make build instead of make install. Second, you could instead try make install BUILDNO=4003 or

set BUILDNO=4003
make install

and be sure to close and then re-open Command Prompt if neither works.

Bfcastilla's picture
Offline
Joined: 09/11/2014 - 09:07
THANK YOU!!!!

I can't believe it!! It worked with "make install BUILDNO=4003"!!

Thank you very much, I really appreciate your help and the time you spent to solve my problem. I am ver grateful to you.

Kind Regards,

Belén.

RobK's picture
Offline
Joined: 04/19/2011 - 21:00
Good to hear!

You're quite welcome, Belén. I'm glad you finally got it to work.

I should mention that I was assuming you were using the most recent revision from the repository, which would have been revision number 4003. If you have to keep setting the BUILDNO variable every time you build from source, you should get it to match the revision number you're actually building from. This should be visible with svnversion entered at the Command Prompt. Ignore any letters in the result, and just use the number you see as the value you provide for BUILDNO.

Log in or register to post comments