You are here

Error when running the demo script 'ThreeFactorScale2Test.R'

4 posts / 0 new
Last post
trinewa's picture
Joined: 11/30/2009 - 06:35
Error when running the demo script 'ThreeFactorScale2Test.R'

When running the demo script 'ThreeFactorScale2Test.R' ( on OpenMx version 1.1.12 I get the following error message:
Error in mxPath(from = latents1, to = indicators1, arrows = 1, connect = "all.pairs", :
unused argument(s) (connect = "all.pairs")

I guess this is the part of the script where the error appears:

threeFactorOrthoRaw1 <- mxModel("threeFactorOrthogonal",
mxPath(from=latents1, to=indicators1,
arrows=1, all=TRUE,
arrows=1, connect="all.pairs",
free=TRUE, values=.2,

From earlier discussion threads I guess this has something to do with the 'all.pairs' and all=TRUE statements, but could someone please help me find the correct way to script this?

tbates's picture
Joined: 07/31/2009 - 14:25
script is fine: Just update openmx

Hi Trini,
the script is fine, you just need to update OpenMx

just execute this in your R console (gets the hot-off-press version, but that's running faster too...)

install.packages('OpenMx', repos='')

trinewa's picture
Joined: 11/30/2009 - 06:35
Problems solved!

Thanks, Tim ,that solved the problem!

mspiegel's picture
Joined: 07/31/2009 - 15:24
Also, pulling scripts from

Also, pulling scripts from the directory ( I mean will work when running the OpenMx 1.1 release.

Log in or register to post comments