You are here

Optimizer + confidence intervals

2 posts / 0 new
Last post
EWilliams's picture
Offline
Joined: 03/08/2016 - 20:24
Optimizer + confidence intervals

Version:
OpenMx version: 2.5.2 [GIT v2.5.2]
R version: R version 3.1.2 (2014-10-31)
Platform: i386-w64-mingw32
Default optimiser: NPSOL

I have been running some bivariate twin models without any problems with the NPSOL optimizer. After installing the latest OpenMx version, however, I keep getting the error : "Error in runHelper(model, frontendStart, intervals, silent, suppressWarnings, : NPSOL is not available in this build. See ?omxGetNPSOL() to download this optimizer".

I tried running my scripts with the CSOLNP optimizer , but this results in output without any confidence intervals (nor for my correlations nor for my estimates).
Could this have anything to do with the new OpenMx version? How can I either get the NPSOL working again, or get the confidence intervals with CSOLNP optimizer?

tbates's picture
Offline
Joined: 07/31/2009 - 14:25
How to get the NPSOL version

TL/DR

source("http://openmx.psyc.virginia.edu/getOpenMx.R")

or

umx_install_OpenMx() # just makes the source call and saves typing/human memory

Long: NPSOL is not open-source, so can't be on CRAN: The OpenMx team maintains a version with NPSOL baked-in on its own server.

Log in or register to post comments