You are here

Invariant Thresholds in Linear Growth Model with Ordinal Data

3 posts / 0 new
Last post
a.ortega's picture
Joined: 02/05/2011 - 08:55
Invariant Thresholds in Linear Growth Model with Ordinal Data
Binary Data Script.R7.38 KB

Hello everyone!
I have prepared a linear growth model to estimate genetic and environmental influences (ACE) in the intake and the slope with ordinal twin data: 3 variables, 7 categories in each of them. The sample is is divided in 6 groups (and so is the script), according to zygosity and sex: MZ men, DZ men, MZ women, DZ women, DZ man-woman and DZ woman-man.
I have been reading from: Mehta PD, Neale MC, Flay BR. Squeezing interval change from ordinal panel
data: latent growth curves with ordinal outcomes. Psychol Methods. 2004 Sep;9(3):301-33; and I understood that the thresholds must be held invariant in order to specify the mean structure. Is this appreciation correct?

I also have tried to adapt a script to do this latent growth model calculations, but the sections concerning the definition of the thresholds doesn't seems to work and the execution of the script returns:
" Error: The algebra 'ACE.ThInc' in model 'lgcOrdACE' generated the error message: non-conformable arguments"

Any help to interpret the meaning of these "invariant thresholds" as well as this error message would be very much appreciated. Is there any possibility to solve it? I have attached the script with the model to help with the issue.

Thanks a lot in advance!

mspiegel's picture
Joined: 07/31/2009 - 15:24
Try running the script under

Try running the script under the OpenMx pre-release and see if the non-conformable arrays error message provides any additional information.

a.ortega's picture
Joined: 02/05/2011 - 08:55
Michael, I tried to install

I tried to install the pre-release, but I am afraid that the package doesn't load in my OSX version of R-cran (x86_64-apple-darwin9.8.0/x86_64). I get the following error message:

> library(OpenMx)
Error in dyn.load(file, DLLpath = DLLpath, ...) :
unable to load shared object '/Library/Frameworks/R.framework/Versions/2.12/Resources/library/OpenMx/libs/x86_64/':
dlopen(/Library/Frameworks/R.framework/Versions/2.12/Resources/library/OpenMx/libs/x86_64/, 6): Library not loaded: /Library/Frameworks/R.framework/Versions/2.11/Resources/lib/libRlapack.dylib
Referenced from: /Library/Frameworks/R.framework/Versions/2.12/Resources/library/OpenMx/libs/x86_64/
Reason: image not found
Error: package/namespace load failed for 'OpenMx'

I returned to the "stable" version of OpenMx.
Anyway, I wonder wether there is something wrong in the script with the computation of the matrix "Thinc". Is there something I could try?
Any suggestion would be very appreciated.