You are here

configure: error: npsol library not found

11 posts / 0 new
Last post
rabil's picture
Offline
Joined: 01/14/2010 - 16:47
configure: error: npsol library not found

I'm trying to install the latest build for OpenMx 1.4. But I get an error:

checking for inst/npsol/linux/x86_64/gcc4.9/libnpsol.a... no
configure: error: npsol library not found

I had 1.3.2 installed. Then I installed 2.2.6, but decided I wanted to use 1.4. The installation attempt is shown below. How can I fix this?

> source('http://openmx.psyc.virginia.edu/getOpenMx1.R')
Installing package into ‘/usr/local/lib/R/site-library’
(as ‘lib’ is unspecified)
trying URL 'http://openmx.psyc.virginia.edu/packages/src/contrib/OpenMx_1.4-3532.tar.gz'
Content type 'application/x-gzip' length 8998725 bytes (8.6 Mb)

opened URL

downloaded 8.6 Mb

  • installing source package ‘OpenMx’ ...
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for gcc option to support OpenMP... -fopenmp
    checking whether gcc is installed... yes
    checking build system type... x86_64-unknown-linux-gnu
    checking host system type... x86_64-unknown-linux-gnu
    checking if gcc accepts -dumpversion option... yes
    checking gcc version... 4.9.1
    checking for gawk... gawk
    checking for inst/npsol/linux/x86_64/gcc4.9/libnpsol.a... no
    configure: error: npsol library not found
    ERROR: configuration failed for package ‘OpenMx’
  • removing ‘/usr/local/lib/R/site-library/OpenMx’
  • restoring previous ‘/usr/local/lib/R/site-library/OpenMx’

The downloaded source packages are in
‘/tmp/RtmpvAb6H3/downloaded_packages’
Warning message:
In install.packages(pkgs = c("OpenMx"), repos = repos) :
installation of package ‘OpenMx’ had non-zero exit status

jpritikin's picture
Offline
Joined: 05/24/2012 - 00:35
can you try

See https://github.com/OpenMx/OpenMx/tree/oldstable

Do you know how to install this? You'll need to 'make install'

rabil's picture
Offline
Joined: 01/14/2010 - 16:47
How to Proceed?

Hi. I'm familiar with compiling but not using github. Not sure how to download so I can compile.

jpritikin's picture
Offline
Joined: 05/24/2012 - 00:35
look for the download zip button

You don't need to use git or subversion. There should be a "Download ZIP" button the right side. You can unpack that and 'make install'

rabil's picture
Offline
Joined: 01/14/2010 - 16:47
I downloaded and unzipped and

I downloaded and unzipped and then:

rick@rick-H8DM3-2:~/Downloads$ cd OpenMx-oldstable
rick@rick-H8DM3-2:~/Downloads/OpenMx-oldstable$ make install
rm -rf build/*
rm -rf models/passing/temp-files/*
rm -rf models/failing/temp-files/*
cp DESCRIPTION DESCRIPTION.bak
sed '/Version:/d' DESCRIPTION.bak > DESCRIPTION
echo "Version: "1.4"-"1 >> DESCRIPTION
cd build; R CMD build ..
/bin/sh: 1: cd: can't cd to build
* checking for file ‘../DESCRIPTION’ ... NO
Makefile:80: recipe for target 'build/OpenMx_1.4-1.tar.gz' failed
make: *** [build/OpenMx_1.4-1.tar.gz] Error 1
rick@rick-H8DM3-2:~/Downloads/OpenMx-oldstable$ ls
acsite.m4 configure.ac demo docs Makefile NAMESPACE README tests
CHANGES configure.win DESCRIPTION inst man NOTICE src
configure data DESCRIPTION.bak LICENSE models R swift

What am I doing wrong? Thanks.

rabil's picture
Offline
Joined: 01/14/2010 - 16:47
I created a build folder and

I created a build folder and trying again.

rabil's picture
Offline
Joined: 01/14/2010 - 16:47
I did: sudo make install and

I did:

sudo make install

and it looks like it worked.

> library(OpenMx)
> mxVersion()
[1] "1.4-1"

Thanks again!

jpritikin's picture
Offline
Joined: 05/24/2012 - 00:35
version

That's good, but I thought that I bumped the version up to 1.5. I'll have to double check that before we tag this as released.

rabil's picture
Offline
Joined: 01/14/2010 - 16:47
Is this version (1.4-1)

Is this version (1.4-1) usable? Is the build number the number after the dash? I am very confused. The reason I wanted to re-install OpenMx was to avoid the problem listed below:

IMPORTANT: if you are running R 3.1 AND your version of OpenMx is 1.3.2-xxxx or 1.4-xxxx, where xxxx is less than 3475, please re-install OpenMx and re-run any analyses you did with it in R 3.1. Version 3.1 of R introduced a small change in R's interface with compiled code that could potentially cause certain OpenMx scripts to compute numerically incorrect solutions. This problem was fixed as of revision number 3475.

This is the version of R:
$version.string
[1] "R version 3.1.1 (2014-07-10)"

jpritikin's picture
Offline
Joined: 05/24/2012 - 00:35
confusing versions

You should be good. I based this version on the latest 1.4.

jpritikin's picture
Offline
Joined: 05/24/2012 - 00:35
manual steps

Hopefully this is automated now.