You are here

Fail to install OpenMx on Ubuntu

3 posts / 0 new
Last post
saralonn's picture
Joined: 12/11/2012 - 09:04
Fail to install OpenMx on Ubuntu
Plain text icon config.txt5.24 KB

I am trying to install OpenMx under R 3.0.2 on Linux (Ubuntu) but without success and get the following error message, could you please help me understand what is the problem?

Have tried to run it both as root and as an ordinary user. With the same results during the build process.
The config.log file from the configure build script is attached.

Below you find the output from when I try to download, build and install OpenMx and if I run the configure script manually ( ./configure) the build process will result in the same error.

sysadmin@cpf-calc1:/var/run$ sudo -i R
[sudo] password for sysadmin:

R version 3.0.2 (2013-09-25) -- "Frisbee Sailing"
Copyright (C) 2013 The R Foundation for Statistical Computing
Platform: x86_64-pc-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

Natural language support but running in an English locale

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.

> source('')
1. single-threaded
2. multi-threaded [default]
Which version of OpenMx should I install? 2
Installing package into â/usr/local/lib/R/site-libraryâ
(as âlibâ is unspecified)
trying URL ' _1.3.2-2301.tar.gz'
Content type 'application/x-gzip' length 7964596 bytes (7.6 Mb)

opened URL

downloaded 7.6 Mb

  • installing source package âOpenMxâ ...
    checking for gcc... gcc
    checking whether the C compiler works... no
    configure: error: in /tmp/Rtmp5xOVsd/R.INSTALL7aeb1d265969/OpenMx':
    configure: error: C compiler cannot create executables
    config.log' for more details
    ERROR: configuration failed for package âOpenMxâ
  • removing â/usr/local/lib/R/site-library/OpenMxâ

The downloaded source packages are in
Warning message:
In install.packages(pkgs = c("OpenMx"), repos = repos) :
installation of package âOpenMxâ had non-zero exit status

root@cpf-calc1:/tmp/RtmpqzJVRD/downloaded_packages/OpenMx# cat /etc/issue
Ubuntu 12.04.4 LTS \n \l


Thank you!


mhunter's picture
Joined: 07/31/2009 - 15:26
Hmm ... It's saying you don't

Hmm ... It's saying you don't have gcc. What happens when you type

sysadmin@cpf-calc1:/var/run$ gcc --version

in your terminal?

If you get nothing, or an error, you should probably

$ sudo apt-get update
$ sudo apt-get install build-essential

saralonn's picture
Joined: 12/11/2012 - 09:04
gcc is installed

Thanks, but that did not seem to be it. This is what comes out when typing sysadmin@cpf-calc1:/var/run$ gcc --version

login as: sysadmin
sysadmin@'s password:
Access denied
sysadmin@'s password:
Welcome to Ubuntu 12.04.4 LTS (GNU/Linux 3.5.0-49-generic x86_64)

  • Documentation:

    System information as of Wed May 21 17:09:43 CEST 2014

    System load: 0.0 Processes: 208
    Usage of /home: 0.6% of 1.79TB Users logged in: 0
    Memory usage: 1% IP address for eth0:
    Swap usage: 0%

    Graph this data and manage this system at:

17 packages can be updated.
12 updates are security updates.

Last login: Wed May 21 11:30:05 2014 from
sysadmin@cpf-calc1:~$ gcc -v
Using built-in specs.
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.6/lto- wrapper
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.6.3-1ubu ntu5' --with-bugurl=file:///usr/share/doc/gcc-4.6/README.Bugs --enable-languages =c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.6 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-incl uded-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.6 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-li bstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-pl ugin --enable-objc-gc --disable-werror --with-arch-32=i686 --with-tune=generic - -enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --targ et=x86_64-linux-gnu
Thread model: posix
gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)