You are here

Installation problem with R2.10.1

4 posts / 0 new
Last post
Dorothy Bishop's picture
Joined: 02/04/2010 - 02:20
Installation problem with R2.10.1

Sorry folks. I've not been using R or OpenMx for about a year and am very rusty. Just tried to update to latest OpenMx. Seemed to work and I can see the folder for OpenMx in my R library directory, but I get error message if I require(OpenMx). So console is as follows:
> source('')
trying URL ''
Content type 'application/zip' length 2298749 bytes (2.2 Mb)
opened URL
downloaded 2.2 Mb

package 'OpenMx' successfully unpacked and MD5 sums checked

The downloaded packages are in
C:\Documents and Settings\dbishop\Local Settings\Temp\RtmpQfKr8q\downloaded_packages
> require(OpenMx)
Loading required package: OpenMx
Error in registerS3method(Info[i, 1], Info[i, 2], Info[i, 3], env) :
no slot of name "methods" for this object of class "derivedDefaultMethod"
In addition: Warning message:
package 'OpenMx' was built under R version 2.11.0

rgore's picture
Joined: 01/27/2011 - 16:48
RE: Installation problem with R2.10.1

Hi Dorothy,
I am going to send you these instructions via email as well but if you get a chance could you try to do the following:
1. Exit R
2. Reopen R
3. Install R again ('')

This worked for Jean, I though it was something specific due to her earlier trouble with installing OpenMx 1.1 but it appears it may be a larger systemic issues.

Out of curiosity what version of Windows OS are you running? Thanks for your patience.

Dorothy Bishop's picture
Joined: 02/04/2010 - 02:20
installation problems fixed

Thanks. I reinstalled R (version 2.13.1) and now all is working fine.

mspiegel's picture
Joined: 07/31/2009 - 15:24
Google-ing for this error

Google-ing for this error message shows that other people had similar problems when installing R packages on R 2.10.x that were compiled for R 2.11.x. Unfortunately they don't have any solutions other than "I upgraded R and now it is working." Is it possible to upgrade R on that machine? We currently build binaries under windows for R 2.11.x and 2.12.x.