You are here

Error: The name '-2sumll' is illegal

5 posts / 0 new
Last post
jarrode28's picture
Offline
Joined: 03/01/2010 - 23:32
Error: The name '-2sumll' is illegal

Hi Everyone,

I've been running basic, univariate twin models over the last week and have had no troubles, but today (March 14) I began receiving the following error in response to this code. The code is nearly identical to the code used at the Twin Workshop, with the exception of different variables and had worked fine up until now even with the new variables. Any ideas of what might be causing this (it seems like a technical issue rather than a modeling issue, but I may be wrong)?

Thanks,
Jarrod

+ mxAlgebra( MZ.objective + DZ.objective, name="-2sumll" ),
+ mxAlgebraObjective("-2sumll")
+ )
Error: The name '-2sumll' is illegal because it contains the '-' character.

mspiegel's picture
Offline
Joined: 07/31/2009 - 15:24
Yup. All of the following

Yup. All of the following characters are now illegal in names: "+-!~?:*/^%=&|$" The reason for this is that these characters can be confused with R operators. Rename the algebra to something like "minus2sumll" and it will work.

jarrode28's picture
Offline
Joined: 03/01/2010 - 23:32
Thanks for the response (it

Thanks for the response (it makes sense). However, I am currently getting several additional errors that I previously hadn't (at the time I thought they were all stemming from the initial error in response). Namely, I now get these errors:

> parameterSpecifications(univTwinSatFit)
Error: could not find function "parameterSpecifications"
> expectedMeansCovariances(univTwinSatFit)
Error: could not find function "expectedMeansCovariances"
> tableFitStatistics(univTwinSatFit)
Error: could not find function "tableFitStatistics"

Is there a section on the website I should be checking for changes to the OpenMx package that may help answer these questions (while saving you all some time)?

mspiegel's picture
Offline
Joined: 07/31/2009 - 15:24
These errors appear because

These errors appear because the gen_epi helper functions are not loaded into your environment. You need to source( "http://www.vipbg.vcu.edu/~vipbg/Tc24/GenEpiHelperFunctions.R"). WRT your other question, the changelog for OpenMx can be found here. But I'm not sure if it would have helped you track down this particular error.

yishan's picture
Offline
Joined: 03/06/2012 - 00:08
Thank you. I was reviewing

Thank you. I was reviewing the workshop stuff and wrote the CE model. This error keeps on jumping out. Your source code is really helpful!

Log in or register to post comments