You are here

bug report forum?

8 posts / 0 new
Last post
carey's picture
Offline
Joined: 10/19/2009 - 15:38
bug report forum?

(1) i know that forums are for discussion, but i cannot find a place on the website for potential bug reports. would a forum of this name be useful?

(2) here is a place to start. submit the following:
library(OpenMx)
thisOMxModel thisOMxModel Efac thisOMxModel testit testit

(3) i get errors on both the first and second "testit" object assignments. have no clue whether this is a bug in OpenMx or a problem with insufficient documentation on the "remove" option. pardon stupidity--am just learning R.

greg

mspiegel's picture
Offline
Joined: 07/31/2009 - 15:24
Hi Greg, For now we are using

Hi Greg,

For now we are using the message forums as the location for the users to post bugs. If a developer opens a ticket on that bug, then usually a link will be provided in the forum comments to track the ticket status. We may switch over to public issue tickets, but this is something the development team will need to decide as a group.

carey's picture
Offline
Joined: 10/19/2009 - 15:38
am confused. should i just

am confused. should i just post suspected bugs to this forum or is there a special "message forum" that i need to access.
greg

tbates's picture
Offline
Joined: 07/31/2009 - 14:25
hi greg, just post suspected

hi greg,
just post suspected bugs to this forum - there is no special "message forum"
best,
t

tbates's picture
Offline
Joined: 07/31/2009 - 14:25
In this

In this line,
mxModel(thisOMxModel, mxMatrix(name=Afac), remove=TRUE)
# Error in single.na(name) : object 'Afac' not found

The error arises because the name "Afac" is a string, but is not in quotes. also, mxMatrix will verify the matrix being created and throw an error (no row,col specified), before passing this on to mxModel to evaluate with remove = T.

So less error prone to provide the actual matrix you wish to remove, not just something with the same name.

mspiegel's picture
Offline
Joined: 07/31/2009 - 15:24
The behavior of OpenMx 0.2.2

The behavior of OpenMx 0.2.2 is to assume string arguments in mxModel() when remove=TRUE. I apologize this was not documented. So the following code segment would work in the current library:

library(OpenMx)
thisOMxModel 

I've checked in a patch to our code repository so in OpenMx 0.2.3 you will be able to mix character strings and named entities when using mxModel(..., remove=TRUE). When the next version is released, then the following example will work:

library(OpenMx)
thisOMxModel 

Thank you for bringing this to our attention!

mspiegel's picture
Offline
Joined: 07/31/2009 - 15:24
Added FAQ entry about named

Added FAQ entry about named entities: http://openmx.psyc.virginia.edu/wiki/faq-openmx#What_is_a_named_entity

ptaylor's picture
Offline
Joined: 05/13/2010 - 17:25
Very nice, thank you!

Very nice, thank you!

Log in or register to post comments