You are here

BLAS/LAPACK routine 'DSYMV ' gave error code -5 from runHelper

4 posts / 0 new
Last post
tbates's picture
Offline
Joined: 07/31/2009 - 14:25
BLAS/LAPACK routine 'DSYMV ' gave error code -5 from runHelper

hi all,
running a simple model f1->{a,b,c} where a & b are ordinal.

runs fine with cov data, or as a raw model, treating the ordinal variables as continuous.

But going to raw with a thresholds matrix and means, it returns the following error.

> m1 = mxRun(m1);
Running m1
Error in runHelper(model, frontendStart, intervals, silent, suppressWarnings, :
BLAS/LAPACK routine 'DSYMV ' gave error code -5

tbrick's picture
Offline
Joined: 07/31/2009 - 15:10
You should at least be getting a better error message

You should at least be getting a better error message than that, so that qualifies it as a bug.

Can you post the script and data that illustrates the issue and let us know which version of OpenMx you're using? I'll try to fix it right away if I can.

Thanks for finding this and reporting it!

tbates's picture
Offline
Joined: 07/31/2009 - 14:25
can't pull the version

hi tim,
I have trolled back over the commit repo for the script that generated this, and can't get the version that errors... I must not have saved it.

For what it is worth, it was present only for a model run as mixed ordinal continuous with raw data with missings: versions with cov, or treating things as continuous, or with no missings ran fine...

Sorry I didn't save this to disk at the time...

tim

tbrick's picture
Offline
Joined: 07/31/2009 - 15:10
Not a problem. Thanks for

Not a problem.

Thanks for bringing it up anyway, and for the pointers about what was going on. When I have some time, I'll go digging around in the code to see if I can find it--between these hints and the error message itself, I might be able to track it down. Or at least replicate it myself.

And if it happens again, don't hesitate to let us know.

Thanks again!

Log in or register to post comments